Can't run app after flathub-builder

For some reason I get this warning when I try to run my app, and the app never opens.

flatpak run org.ccextractor.gui

** (ccxgui:2): WARNING **: 02:25:23.538: Failed to register: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: org.freedesktop.DBus.Error.ServiceUnknown

Tried changing the runtime and sdk too, still same error. What am I missing?
The manifest looks like this atm →

    "app-id": "org.ccextractor.gui",
    "runtime": "org.freedesktop.Platform",
    "runtime-version": "20.08",
    "sdk": "org.freedesktop.Sdk",
    "command": "ccxgui",
    "separate-locales": false,
    "finish-args": [
    "modules": [
            "name": "ccxgui",
            "buildsystem": "simple",
            "only-arches": [
            "build-commands": [
                "cd ccxgui && mkdir lib/ data/ && mv flutter_assets icudtl.dat data/ && mv lib*.so lib/",
                "ls ccxgui",
                "cp -r ccxgui /app/ccxgui",
                "chmod +x /app/ccxgui/ccxgui",
                "mkdir /app/bin",
                "ln -s /app/ccxgui/ccxgui /app/bin/ccxgui"
            "sources": [
                    "type": "archive",
                    "only-arches": [
                    "url": "",
                    "dest": "ccxgui",
                    "sha256": "a87033f0e11572ba948765099b95b6776b2be7f34253f20885bd2e8621441013"

Looks like you need to grant some D-Bus permissions.

Flatpak has a command line to dump what kind of d-bus access is being attempted.