Git source files and No such file or directory

I’m working on the beta branch of an application I package,
one of the steps downloads a git repository and installs the content:

This step works fine when I flatpak-builder on my own pc, but doesn’t work on flathub.

Can anyone shed some light onto it?

The error from the log is:
bash: No such file or directory

First, you don’t need to prepend bash to execute a shell file, just put the file path directly, like can be seen here.

So, try with ""

If failed, try with "./"

If still don’t work, you can download the file directly from git as a individual "file" like can be seen here

Hopefully some of these options will work for you. Let us know!

"" doesn’t work at all, not even on my pc.
"./" works on my pc but doesn’t work on flathub.

I could try to download the file, but what’s the appropriate channel to flag the issue with flathub? This is most likely a bug in the worker servers that should be addressed.

There is no network access during the build, so I don’t see how this can work on the builders.

That file is contained in the git repository downloaded with this json:
“type”: “git”,
“url”: “”,
“branch”: “master”

so it doesn’t need network access, am I missing something here?
What is the right way to download sources from a git repository?

This seems to be your problem:

(flatpak-builder:1135937): flatpak-builder-WARNING **: 14:56:24.915: Invalid source: No slashes allowed in dest-filename

Modules Script Failing on Flathub, worked fine 3 months ago
flatpak-builder 1.0.14 breaks build of org.libreoffice.LibreOffice, empty /run/build/libreoffice

You have to remove the relative path from dest-filename:

  "type": "file",
  "path": "sources/pjproject-2.10.tar.gz",
  "dest-filename": "deps/2.10.tar.gz"


  "type": "file",
  "path": "sources/pjproject-2.10.tar.gz",
  "dest": "deps"
  "dest-filename": "2.10.tar.gz"