Audacious Flatpak Local Skins Folder

Hello! I’m new to using Flatpak programs but really like the idea of each app having it’s own “container” so I don’t break as many things with an update. One thing I did want to ask is where to place winamp skins for Audacious to use. In a normal apt installation, they go in /usr/share/audacious/Skins/ for system-wide installation, or ~/.local/share/audacious/Skins/ for local installation. How would this translate to the Flatpak file system?

Hello @Gnollhide. If you installed Audacious as user-wide then you should put your skins into:


Thank you! I had installed the flatpak as a user, but didn’t see that folder stack in .local at all. I tried recreating it, but pasting them into there changed nothing. However, I did find that file list under /var/lib/flatpak instead, and copying them into that skins folder worked perfectly!

Isn’t this going to be reverted on the next update? I believe you shouldn’t modify the Flatpak installation.

Audacious seems to follow the XDG Base Directory Specification. You can put your skins into:


In general, ~/.var/app/<app-id> is an app specific folder where flatpak puts the XDG folders (& others, too).

As an alternative you can probably define SKINSDIR as an environment variable to any folder you like (I haven’t tested this, it’s what the manpage says). You can set it with flatpak override:

flatpak override --user org.atheme.audacious --env=SKINSDIR=~/audacious-skins

Oh, thank you! I looked and that folder didn’t exist either, but after creating it and putting in a different skin file it works great! I hate having to sudo copy things to /var/, so having a home folder solution works much better.

You don’t need sudo either for $HOME/.local/share/flatpak/app/foo but ~/.var/app/org.atheme.audacious/data/audacious/Skins for sure right answer for such things.

I had installed the flatpak as a user

/var/lib/flatpak mean you installed it system-wide, not user-wide.

Oh my apologies! I thought that not specifying the user when installing a flatpak using the flatpak install (whatever) meant that it was just automatically dumped in $HOME and it was considered a user-only app. I’ll keep this in mind going forward, thank you!