BeeRef: a tool for artists about references images (GNU/GPL3)

Picture: A screenshot of BeeRef in action (panel on left, resised at 1/4 of my monitor, other 3/4 is Krita.)

Project information:
BeeRef is a tool for artists: it lets you quickly arrange on a canvas your reference images and view them while you create. Its minimal interface is designed not to get in the way of your creative process. It’s great!

If BeeRef had a Flatpak, I would include it on my yearly Linux install Guide for Artists. Right now, it is only on the ‘Advanced’ appendice of the article as it require to download the pre-compiled archive, unpack it, and copy a *.desktop file (provided) along with a PNG logo to get a nice menu entry. A procedure a little bit too complex that Flatpak could simplify a lot.

The project hasn’t a lot of update since 2021, and BeeRef is really stable as it is. BeeRef probably requires permissions: drag and drop of files (or URL, eg. from Firefox image search) on it’s canvas. Drag’n’drop of files from file explorer. Possiblity to save/load BeeRef files and access to clipboard.

I’m ready to be active for user feedback and testing. And, if I receive guidance (mentorship?) I’m willing to learn how to make this project myself too (but I’m not a dev, so I might have big flaws to understand too technical documentation).


Happy to give this one a shot with all the info you provided :smile:. Feel free to test the Flatpak here @davidrevoy

Keep in mind this is using the latest tagged release (0.2.0) - There have been updates to BeeRef since, but they’re not tagged in a release. If you want those changes, message the app dev again and ask them to create a new release

There’s also a crashing bug someone made a PR for here that upstream should probably merge:

Hey, thank you very much @dginovker ! :beers:

So, I tested the flatpak, and for that, I followed the advices of the bot on Github with the line:

flatpak install --user

Everything worked fine here for the install process (Fedora 36 KDE, X11/Mesa/ AMD Ryzen 7 3700X (16) @ 3.600GHz / AMD ATI Radeon RX 5500/5500M / Pro 5500M / KDE Plasma 5.24.5 ).

Version 0.2.0 is a solid choice; that was the one I had installed on my OS since November 2021.

I met mainly two important usability issues with the Flatpak:

  1. The drag and drop of pictures from file explorer (eg. a JPG from Dolphin) is not authorised; this is happening when I test it: (video, mp4, 71Kb), It’s similar with drag’n’drop from Firefox. (things that worked: Right click + copy link, and paste on BeeRef. So I guess clipboard is working well. Also, using the Insert from Beeref and fileexplorer built-in Beeref to add a reference did work).

  2. It’s not possible to save the Beeref file right now. I tried to save a random ‘rrr’ file to /home/deevad, I had the file browser opening, I could find my home directory without any issue and name my files, but then, when I press OK; a dialog appears and tell me I tried to save to another path /run/user/1000/doc/9b8433e0/, and the directory is not accessible ( screenshot of the dialog: )

I hope this two issues can be solved without taking too much of your time, I’m really grateful for the time you already spent to make this wish a reality.

(ps: I received your email; but I prefered to reply here. Let me know if you prefer to continue on email, here or on Github, no problem!)

I can fix these issues by providing access to --filesystem host. I’ll find out if that’s allowed.

(Technically BeeRef is supposed to use File Dialogs so it supports sandboxing but it’s a stable/unupdated project so I doubt they’d make the change)

Made another build in the thread, issues should be fixed

1 Like

Thanks! Ok, I uninstalled the previous Flatpak, I did:

flatpak list

To get the name then

flatpak uninstall org.beeref.BeeRef

then, I installed the latest build:

flatpak install --user

It looks like this is a good method to update the build because now BeeRef can receive drag’n’drop from the File Explorer (Dolphin), and I tested various path and extension. Very cool :+1: And I can also Save *.bee files on my home directory at will.

It remains only the drag’n’drop from Firefox that is not allowed, I have this dialog:

Maybe it is because Firefox uses the /tmp/ directory as a transitional way to save a copy on the disk, and the flatpak can’t load or give access to this directory?

Thanks for the improvements!

/tmp is blacklisted, so I can’t make BeeRef support it here (which is a shame since the convenience of BeeRef is what makes it desirable)

Ha thanks. I just read a little about it, and it sounds indeed like a large topic.

The workaround will be to right-click > Copy Image and paste in BeeRef. I can live with it; but it will probably need to be mentioned on the description to avoid getting it as a bug report in the future. :smile:

Looks like it’s a limitation of the KDE runtime that the BeeRef Flatpak uses (can’t switch it to the normal one since it’s a QT app). My understanding is as the KDE runtime gets updated to support the FileTransfer protocol, it’ll add support for drag 'n drop.

I’ve added a note to the appdata.xml (the thing that shows up on about this. I think it’s otherwise good to merge, just double checking my assumption about KDE’s runtime is correct :+1:

It’s all ok to merge, and thank you again for the very good work. :+1: