Cannot install GitKraken

I tried to install GitKraken, but the following message appeared, and the installation did not complete.

$ flatpak install --user flathub com.axosoft.GitKraken
Installing in user:
com.axosoft.GitKraken/x86_64/stable flathub b054725f1d64
permissions: ipc, network, pulseaudio, ssh-auth, x11, dri
file access: host, xdg-run/gvfs
dbus access: org.freedesktop.Flatpak, org.freedesktop.Notifications, org.freedesktop.secrets, org.gtk.vfs, org.gtk.vfs.*
tags: proprietary
Is this ok [y/n]: y
Installing for user: com.axosoft.GitKraken/x86_64/stable from flathub
[##= ] Downloading files: 114/114 4.3 MB
error: Failed to install com.axosoft.GitKraken/x86_64/stable: While downloading Server returned status 404: Not Found

Seems to be temporary hiccup. It installed fine for me just now.

I tried again today, but that situation has not changed.

$ curl -f
curl: (22) The requested URL returned error: 404 Not Found

❯ curl -I
HTTP/2 200 
date: Mon, 09 Mar 2020 08:35:49 GMT
content-type: application/octet-stream
content-length: 74301672
set-cookie: __cfduid=d204d70db524df062305f269402d4534f1583742949; expires=Wed, 08-Apr-20 08:35:49 GMT; path=/;; HttpOnly; SameSite=Lax; Secure
last-modified: Thu, 20 Feb 2020 22:30:47 GMT
etag: "5e4f0897-46dc0e8"
access-control-allow-origin: *
access-control-allow-credentials: true
access-control-allow-methods: GET
access-control-allow-headers: DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type
cache-control: max-age=14400
cf-cache-status: HIT
age: 341339
accept-ranges: bytes
expect-ct: max-age=604800, report-uri=""
server: cloudflare
cf-ray: 571376f8df42ffc8-WAW

You should probably ask GitKraken if then can do anything about it. It works from here. Flatpak just downloads that URL during installation so it’s beyond our control.

Thank you for your reply. I will ask GitKraken.