ChromeOS: Unable to load summary from remote flathub

so I was downloading apps and for all of the apps I got this error

Unable to load summary from remote flathub: Signature made Thu 06 Jul 2023 03:47:36 PM AST using RSA key ID 562702E9E3ED7EE8
Can’t check signature: public key not found

I don’t know what to do, please help

I guess you followed Chrome OS Flathub Setup | Flathub to set this up? Unfortuantly I don’t have ChromeOS to test.

Did you run sudo apt update to update the debian install before running the flatpak installs?

I did do **sudo apt update** and i also did **sudo apt upgrade** and I even did both system and user downloads for an app. none worked.
still am getting the same error

So can you figure out which version of debian it’s running maybe?

Sadly, i had to powerwash my chromebook
On the good side, its way less laggy and flatpak and flathub works!

Can you say what exactly you did? For other users, that might have this problem?

Like Can't check signature: public key not found · Issue #3521 · flathub/flathub · GitHub

Basically, all I did was powerwash my chromebook, restart it after powerwashing, installed linux again, installed flatpak using the install guide. And finally I could install apps, but i cant install some apps like Audacity, Minecraft, Grapejuice and Vinegar, OBS. But it still installs some apps. Glad to help

1 Like