Difficulty Installing Firefox

I am new to Flatpak. I attempted to install Flatpak and Firefox on a RPi 4B running an updated Raspian Buster - kernel 4.19 using instructions I found here:
https://www.networkshinobi.com/flatpak-and-raspberry-pi/

Install of Flatpak went fine and I then installed Firefox with this command:
flatpak install flathub org.mozilla.firefox

Flatpak found the ref ‘app/or.mozilla.Firefox.BaseApp.arm.stable’ in remote 'flathub, installed 5 components and completed with the message: 'Installation complete.

I then attempted to run Firefox with the command:
flatpak run org.mozilla.firefox

The message I get is:
error: app/org.mozilla.Firefox/arm.master not installed

If I attempt to re-install, I get the message:
Skipping: /org.mozilla.Firefox.BaseApp/arm/stable is already installed

Any ideas how to correct whatever I am doing wrong.

Thank you.

Mozilla ships binaries only for x86_64. Requested build for aarch64 on their bug tracker; when it’s available it will be also published to Flathub.

Just curious. What does the ‘arm’ in ’ /org.mozilla.Firefox.BaseApp/arm/stable’ refer to?

We have built the base app which Mozilla uses to build upon for all architectures by mistake. I will delete it to avoid confusion.

I’ve had the same question. I’m not running armhf-64, but armhf-32. On all the way from a PiZW to the P4b-4gb. The 64 bit OS is still a BETA. Not ready to go there. I have the .img. Not in the mood. I’ve been a Beta person for a long time. Just taking an OS Beta break. LOL

I’m having difficulty too. I’m not very savvy about Linux or Flatpak.

Update: The answer is at bottom of this post.

Running 32-bit Chromebook, Version 84.0.4147.136 (Official Build) (32-bit). From earlier in this thread, I think it says 32-bit Firefox is not available/supported through Flatpak. Maybe I should give up, but here’s what I did before coming to this forum.

I followed instructions here: https://flatpak.org/setup/Chrome%20OS/
On step 4 (add Flathub repository), I got an error the first time. I don’t remember what it was. Tried again and it worked. Restarted the Chromebook.

(New users of forum can only post two links so I’ve removed the link constructs)
I went to “https colon slash slash flathub dot org slash apps slash details dot org dot mozilla dot firefox”
and hit the install button for Firefox, which put the “org dot mozilla dot firefox dot flatpakref” file in my downloads folder.

At the bottom of the page it says to open a Linux terminal window and type this command:
flatpak install flathub org dot mozilla dot firefox
The system replies:
error: Nothing matches org dot mozilla dot firefox in remote flathub

Any ideas?

I’m just trying to get the bookmarks toolbar to show up in Firefox on my Chromebook. Using the Android version of Firefox on Chromebook, there’s no option to show the Bookmarks toolbar.

I don’t like Chrome. I use Firefox. I suppose I could import my Firefox bookmarks into Chrome if I had to.

Also, I downloaded the 32-bit version of Firefox for 32-bit Linux here:
“https colon slash slash www dot mozilla dot org slash en-US slash firefox slash all slash #product-desktop-release
but I have no idea how to install it using the command line in the terminal window. Nor do I know whether it would work or cause damage.

Update: my son gave me the answer. Use this command:
sudo apt install firefox-esr
It works!

Only x86_64 is supported by Firefox on Flathub.