Errror on launching a flatpak app

Hi, I’m trying to package my first flatpak app. It is a flutter app, I followed this example.
I’ve setup all the files and if I run

flatpak-builder --force-clean build-dir com.ferrarid.converternow.json

the process succeed. But if I try to install the app on my PC with

flatpak-builder --user --install --force-clean build-dir com.ferrarid.converternow.json

and then I launch the app with

flatpak run com.ferrarid.converternow

I get the following error:

converternow: /usr/lib/x86_64-linux-gnu/ version 'GLIBC_2.34' not found (required by converternow)

What should I do? Thanks in advance!

This is my first post, I’m not sure this is the correct section.

Where the binaries were build, it was with glibc 2.34, which is too recent for the freedesktop-sdk. They are also likely to fail on any other distro that people use, so it’s not an exception.

Ideally you’d build everything inside with flatpak (don’t ask me how I don’t know Flutter) instead of repacking random binaries.

Thank you! That’s strange because I built the app, the flatpak and installed the app all with the same PC. Anyway, I managed to build the app within a containerized environment and now it works! Thank you!

“on the same PC”.

flatpak is sandboxed, which include the libc that is not the one you have on your host PC. Freedesktop-sdk 21.08 only has 2.33.

Which is also why it is better to build from source inside flatpak to make a flatpak.