Flathub Steam Link broken?

Hello, I’ve been trying to install Steam over Flathub for about 4 hours. I could install other packages without any problems.

flathub com.valvesoftware.Steam


Every time it tells me, there are no matches on flathub.

So what am I doing wrong, can one of you check if it is my fault or if the link is really broken.


ok, here some more information:

Gimp, VLC, Libre and Visual Code are easily installed

i have tried both ways, the hub link and the file, but it didn’t work.

With vlc and Gimp the installation via the file worked without problems. (With them i tried both possibilities).

i just noticed that the link for firefox and PyCharm did not work either. Is this maybe because of ChromOS ?

Holy crap im having this same issue, this is an old thread, i know. Did you happen to fix this??

Steam, Firefox & PyCharm were & are x86_64 only. The original poster was running ChromeOS therefore most likely arm or aarch64.

You should check your cpu architecture, too.