Flatpak app suddenly stopped running - gives permission error

Hello, I have been using org.signal.Signal for about a year now. It has worked great with no issues until now. Today I clicked the app to open it, and nothing happend, so I tried from the console:

$ flatpak run org.signal.Signal
error: Not allowed to query parental controls data for user 1000

I am not sure why or where this error came from, so I just tried reinstalling the app, which when I try to add it back now results in:

Failed to install org.signal.Signal: Error deploying: Not allowed to query parental controls data for user 1000

Can anyone point me in the right direction on how to troubleshoot something like this?


I am facing the same problem, on Fedora 37.

Some apps (OBS Studio, Obsidian, Chrome, Kotatogram Desktop) were working, but others (Brave, Flatseal) stopped working.

So I decided to: Uninstall all the apps → Uninstall flatpak using dnf → Reinstall flatpak and add flathub remote → Try installing Google Chrome from flathub

And now other apps also fail installing with the same error.

Okay so I managed to fix it somehow:
NOTE: Do this only if you know what you are doing!

  1. Uninstall all apps using flatpak uninstall

  2. Uninstall flatpak using your package manager:

    • Fedora: sudo dnf remove flatpak
    • Ubuntu: sudo apt purge flatpak
  3. Remove flatpak folders from /

# Cache
sudo rm /var/tmp/flatpak-cache* -rf
sudo rm /var/cache/swcatalog/cache/*flatpak* -rf
rm ~/.cache/flatpak -rf

# System files for flatpak
sudo rm /run/user/1000/.flatpak* -rf
sudo rm /var/lib/flatpak -rf

# flatpak (user)
rm ~/.local/share/flatpak -rf
rm ~/.var/app -rf  
  1. Reboot your system

  2. Install flatpak:

    • Fedora: sudo dnf install flatpak
    • Ubuntu: sudo apt install flatpak
  3. Done! Now add flathub remote and try installing something.