Flatpak build problem

Flatpak itself seem to not have it’s own forum and google sent me here.

I need to set environment variables for my cmake build system but i get reported that the “env” property is unknown despite being listed in the very sparse reference documentation.

“Unknown property env for type BuilderModule”.

It’s hard without seeing the manifest, but I’m gonna guess that you are putting a “env” in the wrong place.

It should be:

"modules": [
    "name": "my_module",
    "build-options": {
      "env": {