Flatpak-builder constructing repeating filename

I’m doing some basic checks (on a cut-down version) before updating my app from

runtime: org.gnome.Platform
runtime-version: “3.38”


runtime-version: “40”

This is the relevant bit of the manifest:


I keep getting the error (on either runtime):

Successfully installed Pillow
Error: module python3-pillow: Error when getting information for file “/home/chris/flatpak/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/rofiles/rofiles-sXgi2S/.flatpak-builder/git/https_github.com_myapp/objects/pack/pack-da9b70b334cbb58385a7a9d43d76a07248816692.idx”: File name too long
FB: Unmounting read-only fs: fusermount -uz /home/chris/flatpak/.flatpak-builder/rofiles/rofiles-sXgi2S

I have edited out many lines. It seems this filename is in an endless loop of adding to itself over and over again. I’ve seen this before and wasn’t able to fix it.

I’ve never seen this before. I have no idea and I could only make some trial&error attempts. Can you put a link to the repository so we can test it?

@fedelibre No bugs have been reported, so I haven’t looked at this for about 6 months, so I might be a bit rusty and have done something stupid. (I’m running it on Fedora-35-Beta, but that isn’t the problem as it did it on Ubuntu Budgie 20.10 or 21.04) This is just a cut down version without the main part of the app to test the basics:

app-id: com.github.test.test

runtime: org.gnome.Platform
runtime-version: “40”
sdk: org.gnome.Sdk

command: test
copy-icon: true

  • –share=ipc
  • –socket=fallback-x11
  • –socket=wayland
  • –filesystem=host:rw


@fedelibre Solved by deleting ~/.flatpak-builder.
I’ve been using --force-clean but forgotten about a cache of previous attempts in ~./flatpak-builder. There’s probably a command-line parameter to delete this.

It started when I tried switching from using the .yml format for my manifest to the .json format.