Flatpak doesn't work: Unable to load summary from remote flathub: Peer failed to perform TLS handshake

Flatpak doesn’t work: Unable to load summary from remote flathub: Peer failed to perform TLS handshake.

System: Manjaro Linux 19.0.2

Manjaro updates have arrived, but nevertheless Flatpack does not work , the same error appears.
The error does not depend on the version of Manjaro Linux.
A month ago, everything worked. I don’t know what to do with this problem. Guys. I need help.

I was going to tell you to better try to ask at the Manjaro forums but I see that you did it already

In the flathub issue tracker other people complained about this error in 2018 and one of the solutions was about making sure the system clock wasn’t ahead time (see here for more info)

I’m sorry I can’t help you more. It could be useful to know the flatpak version you are using (type flatpak --version) and also if you are using a 32 or 64 bits operating system). It could be also location related (are you connecting from China?)

[helg@Houston ~]$ flatpak --version
Flatpak 1.6.2

64 bits operating system Manjaro Linux 19.0.2

Location: Russia

The error does not depend on the version of Manjaro Linux.
I contacted the provider’s support service, and was told that there are no problems with the connection, I have a “clean” IP.
The clock is also configured correctly, in the system and in the BIOS.


At the same time, when I type wget, the following results are obtained:

[helg@Houston ~]$ wget flathub.org
URL transformed to HTTPS due to an HSTS policy
–2020-03-16 19:44:58-- https://flathub.org/
Loaded CA certificate ‘/etc/ssl/certs/ca-certificates.crt’
Resolving flathub.org (flathub.org)… 93.93.130.103, 93.93.128.161, 2a00:1098:80:4::1, …
Connecting to flathub.org (flathub.org)|93.93.130.103|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 8038 (7.8K) [text/html]
Saving to: ‘index.html’

index.html 100%[=================>] 7.85K --.-KB/s in 0s

2020-03-16 19:44:59 (107 MB/s) - ‘index.html’ saved [8038/8038]


At the same time:

[helg@Houston ~]$ flatpak install flathub com.viber.Viber
Looking for matches?
error: Unable to load summary from remote flathub: Peer failed to perform TLS handshake: Error receiving data: Connection reset by peer


I really don’t know the issue but try to download this file instead, as the repo is hosted at dl.flathub.org

$ wget https://dl.flathub.org/repo/logo.svg

--2020-03-17 07:52:32--  https://dl.flathub.org/repo/logo.svg
Resolving dl.flathub.org (dl.flathub.org)... 151.101.242.217, 2a04:4e42:39::729
Connecting to dl.flathub.org (dl.flathub.org)|151.101.242.217|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13334 (13K) [image/svg+xml]
Saving to: 'logo.svg.1'

logo.svg.1                                           100%[=====================================================================================================================>]  13.02K  --.-KB/s    in 0.001s  

2020-03-17 07:52:34 (22.5 MB/s) - 'logo.svg.1' saved [13334/13334]



[helg@Houston ~]$ wget https://dl.flathub.org/repo/logo.svg
–2020-03-17 17:59:53-- https://dl.flathub.org/repo/logo.svg
Loaded CA certificate ‘/etc/ssl/certs/ca-certificates.crt’
Resolving dl.flathub.org (dl.flathub.org)… 151.101.2.217, 151.101.66.217, 151.101.130.217, …
Connecting to dl.flathub.org (dl.flathub.org)|151.101.2.217|:443… connected.
GnuTLS: Error in the pull function.
Unable to establish SSL connection.

At the same time, if I type in the browser:
https://dl.flathub.org/repo/logo.svg
an image from the file “logo.svg” appears.

What distribution are you using?

Manjaro Linux KDE 19.0.2
64 bit

and even in the early version 18 of Manjaro the same nonsense now, although a month ago everything worked fine.

I installed Elementary OS, and Flatpack doesn’t work either . The same error.

Same here Manjaro 19.0.2 XFCE

Good afternoon! The other day I found out that in the KDE Neon distribution, Flatpack works for me, but for some reason in Manjaro KDE, Manjaro Gnome, as well as in Elementary OS, Flatpak does not work. What can this be related to?

I connected to the Internet via my mobile phone, and then started installing apps via Flatpack.
The most incomprehensible thing about all this is that now the error does not appear when connecting to the wired Internet.
Accordingly, the problem is that the TLS requirements are too strict when installing components:

org.freedesktop.Platform
org.freedesktop.Platform.GL.default
org.freedesktop.Platform.GL.nvidia-440-82
org.freedesktop.Platform.openh264

after installing them, the “Peer failed to perform TLS handshake” error no longer appears. Is it possible to soften the requirements for "TLS handshake"in some way?

Related issues:


I tried everything, nothing helps

Hi,
I tried to type this line on your advice, and this is what happened:

[helg@Houston ~]$ curl -I https://dl.flathub.org/repo/summary.sig
HTTP/2 200
server: nginx/1.14.0 (Ubuntu)
content-type: application/octet-stream
last-modified: Sun, 19 Apr 2020 21:35:43 GMT
etag: “5e9cc42f-250”
expires: Sun, 19 Apr 2020 22:36:23 GMT
cache-control: max-age=3600
strict-transport-security: max-age=15768000
backend-name: 3DxooTFj8SlVTdJ0UTX8Jd–F_front_hex2_https
accept-ranges: bytes
date: Sun, 19 Apr 2020 22:35:58 GMT
via: 1.1 varnish
age: 3574
x-served-by: cache-fra19131-FRA
x-cache: HIT
x-cache-hits: 125
x-timer: S1587335758.295722,VS0,VE0
content-length: 592

Please tell me what this might mean and what to do next?