Flatpak Keepassxc is causing the Deepin V20 1003 "system" to crash when executed

Hello Team Flatpak

I don’t know if the flatpak team is the same, so I would like to know if anyone can help me on this issue:

Flatpak Keepassxc is causing the Deepin V20 1003 “system” to crash when executed.

The PC can only be turned off using the disconnect button after this lockout.
I believe it is raising the CPU to 100%.

I just formatted an HD with Deepin V20 updated with version 1003 precisely because of this problem.
I performed a clean installation and installed one application at a time until I found out who was causing this crash.

I only removed the keepassxc package (flatpak removes org.keepassxc.KeePassXC), but I left the KDE aggregates.
If need to remove KDE as well, tell me the command.

flathub/org.keepassxc.KeePassXC#72

Thank

Could be a GPU driver issue. What’s your GPU?

Does it work, if you start the app with this command:

$ flatpak run --nodevice=all org.keepassxc.KeePassXC

Hello @eszlari

Follow my machine data:

OS: Deepin 20 x86_64
Kernel: 5.4.50-amd64-desktop
Uptime: 20 mins
Packages: 2036 (dpkg), 13 (flatpak)
Shell: bash 5.0.3
Resolution: 1920x1080
DE: Deepin
WM: KWin
WM Theme: light/deepin
Theme: deepin [GTK2/3]
Icons: bloom [GTK2/3]
Terminal: deepin-terminal
Terminal Font: Noto Mono 11
CPU: Intel i3 540 (4) @ 3.067GHz
GPU: Intel Core Processor
Memory: 967MiB / 7698MiB

Installation data follows:

flatpak install flathub org.keepassxc.KeePassXC
Looking for matches…
Runtime exigido para org.keepassxc.KeePassXC/x86_64/stable (runtime/org.kde.Platform/x86_64/5.15) localizado no remoto flathub
Você deseja instalá-lo? [Y/n]: y

org.keepassxc.KeePassXC permissions:
ipc network ssh-auth wayland
x11 devices file access [1] dbus access [2]
bus ownership [3]

[1] /tmp, host, xdg-config/BraveSoftware/Brave-Browser/NativeMessagingHosts:create,
    xdg-config/chromium/NativeMessagingHosts:create,
    xdg-config/google-chrome/NativeMessagingHosts:create, xdg-config/kdeglobals:ro,
    xdg-config/vivaldi/NativeMessagingHosts:create, xdg-run/gvfs,
    ~/.mozilla/native-messaging-hosts:create,
    ~/.tor-browser/app/Browser/TorBrowser/Data/Browser/.mozilla/native-messaging-hosts:create
[2] com.canonical.AppMenu.Registrar, com.canonical.Unity.Session,
    org.freedesktop.Notifications, org.freedesktop.ScreenSaver,                              
    org.freedesktop.login1.Manager, org.freedesktop.login1.Session, org.gnome.ScreenSaver,   
    org.gnome.SessionManager, org.gnome.SessionManager.Presence, org.gtk.vfs, org.gtk.vfs.*, 
    org.kde.StatusNotifierWatcher
[3] org.kde.StatusNotifierItem-2-2, org.kde.StatusNotifierItem-3-2


    ID                            Arch         Ramo        Remote       Baixar
  1. [✓] org.kde.Platform x86_64 5.15 flathub 133,3 MB / 388,3 MB
  2. [✓] org.kde.KStyle.Adwaita x86_64 5.15 flathub 6,1 MB / 6,1 MB
  3. [✓] org.kde.Platform.Locale x86_64 5.15 flathub 755,2 kB / 341,1 MB
  4. [✓] org.keepassxc.KeePassXC x86_64 stable flathub 11,1 MB / 11,2 MB

Installation complete.

Below is an image containing the error presented.

Unfortunately, with the command requested, it also crashed everything and it was necessary to restart the machine with the button shutdown manually.

Your considerations

Serial

Output of

$ journalctl -f

when the crash happens?

Answer: When we run the application either through the terminal using the command or when we click on the application icon to open it.

The requested follows:

Blockquote journalctl -f
Hint: You are currently not seeing messages from other users and the system.
Users in groups ‘adm’, ‘systemd-journal’ can see all messages.
Pass -q to turn off this notice.
– Logs begin at Sun 2020-11-01 20:12:00 -03. –
nov 06 08:06:11 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:06:11 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:06:11 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:06:42 edson-PC6450br deepin-deepinid-daemon[6964]: [WAR] manager.go:216: skip doSync
nov 06 08:09:35 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:09:35 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:09:35 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:09:36 edson-PC6450br deepin-turbo-invoker[11061]: error: Application’s name is not defined.
nov 06 08:09:36 edson-PC6450br startdde[6392]: startmanager.go:580: send openapp message, app info /usr/share/applications/deepin-terminal.desktop/Terminal Deepin/deepin-terminal
nov 06 08:09:36 edson-PC6450br daemon/dock[6531]: app_entry.go:239: attach window id: 83886090, wmClass: “deepin-terminal” “deepin-terminal”, wmState: [], wmWindowType: [389], wmAllowedActions: [516 517 518 519 521 522 523 524 525], hasXEmbedInfo: false, hasWmTransientFor: false
nov 06 08:11:29 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:11:29 edson-PC6450br x-event-monitor[6531]: manager.go:134:
nov 06 08:11:29 edson-PC6450br x-event-monitor[6531]: manager.go:134:

Hello @eszlari

Do you need any more information?
Yesterday out of curiosity I installed on Ubuntu 20.04 LTS and it worked normally, but on Deepin V20 1003 despite the last two updates from the KDE group it remains the same: (Locking everything up)

If it works on other distributions, then you should report this bug to Deepin.