Flatpak refusing to operate on a user installation as root

I am completely new to using Flatpak and am fairly new to Linux in general. I’m using Flatpak it to manage apps on my Batocera machine. I installed Steam using the command line but now when I try to uninstall it, it tells me that it refuses to operate on a user installation as root. I’ve tried SU into other user accounts but none have permission to uninstall apps. I’m sorry if this is the wrong area to look for support but I’m a little lost and would welcome any feedback anyone has.


Lots of detail missing.

First, no idea what Batocera is.

Second, I assume you run flatpak as root or with sudo. Don’t, and that’s probably the source of your problems as it says in the topic title.

@hub Thanks for the reply. Batocera is a Linux distro that uses Flatpak out of the box for plugin installations. I have a decent amount of experience with Ubuntu and Free BSD but nothing ever using Flatpak as its package manager. Before posting, I tried uninstalling using a standard user account but that failed as well due to that account not having permissions for the program in question. I was also not able to grant permission for this program to said user account.

In the end, the solution I came up with that resolved the issue was to do a clean install of Batocera. I wasn’t that far into the setup and the 20 minutes it took me to reinstall seemed like a better use of time. So, unfortunately, I am not able to say I resolved the issue properly but hey, it works.

Thanks again.