Getting error "bwrap: Can't mkdir /tmp/.X11-unix: Permission denied" when trying to open specific app

Hello! I am here to ask for some assistance in fixing an error I believe I had caused with an app not launching.
Currently, when I try and launch Randovania via my terminal, I get this error:

$ flatpak run io.github.randovania.Randovania 
bwrap: Can't mkdir /tmp/.X11-unix: Permission denied

I do not know how to fix it, as I have attempted to uninstall and reinstall randovania.
This is the only application I have on flatpak that is experiencing this problem.

A history of how I got to here is as such (This may be a bit of reading)
I am using both my Browser and Discord on Flatpak, and had wanted to play Randovania. But I realized that Randovania (from github not flatpak. I’ll make it known when the flatpak version comes in play) wasn’t opening my browser to log into.
So I asked around and was recommended to enter the current randovania folder and remove a file called So I did, and this almost worked, as when I went to search for a Multiworld in randovania and was prompted to log in, pressing “log in” would attempt to load my browser. But, sadly, randovania returned this error: /usr/bin/flatpak: symbol lookup error: /usr/lib/ undefined symbol: g_task_set_static_name (it is trying to launch my flatpak browser, but seems to fail)

I had installed the flatpak version of randovania prior to asking around, and had experimented with it prior to knowing that mutliworlds were unsupported, but through this version I was at least able to log into it, I was told this was due to “the flatpak environment ship[ping] the required (outdated) deps”, whereas the current github version does not.

After my attempts with the github version, I had made an attempt that I believe broke the flatpak version of randovania.
I had tried to move my github-extracted Randovania folder to the one flatpak made to replace it, using a command that looks a lot like this: mv /home/user/randovania-6.4.1/ /var/lib/flatpak/app/io.github.randovania.Randovania/x86_64/stable/[some giant string]/files/share/
Prior to this I had also relocated /var/lib/flatpak/..../files/share/randovania somewhere else as well, just so I could return it if this didn’t work.
After running the command, I then renamed randovania-6.4.1 to just randovania and chowned it as root (as the flatpak folder was also root-owned). Made sure the perms were the same. Though thinking about it, maybe it wasn’t wise to make it recursive.

The attempt did not work, it didn’t launch (I forget the error it gave, if any).

But now when I moved the (perm unmodified) original folder back, it would not launch still. Giving me the error at the start of the post.
I checked in flatseal, but it tells me that the perms set are their defaults. I cannot remember if there were any directories given to it under Filesystem/Other Files, but as of current they are empty.

So, with this, I ask:

  • What can I do to fix Randovania on Flatpak? I uninstalled it, deleted its data where I could find it, and reinstalled it, but to no progress.
  • Are there any additional steps for the github version of randovania that would allow it to launch my flatpak-browser and log me in this way?
    I currently have to use a (thankfully preserved) copy of my login instance from flatpak and copy it over to the github login to log into it. If I could figure this out, I would be able to log in using only one variant of Randovania.

Thank you for any help you can provide.

I just realized there’s a flathub issue tracker after sending this, I apologize for the wall. I will forward this to there.