How to revert to Octave 5.2?

I have 2 computers that I wish to use with the same version of Octave, namely 5.2.0 (commit 4c5f24159e70054f4a276f58ac6e0669f8993d902612a7339d93701ee0f71e88 from 2020-10-08). One computer already has the correct version, the second is stuck on Octave 6.2.

What I used to do to install the desired version of Octave was

flatpak install flathub org.octave.Octave
sudo flatpak update --assumeyes --commit=4c5f24159e70054f4a276f58ac6e0669f8993d902612a7339d93701ee0f71e88 org.octave.Octave

This however does not work anymore (It used to a few months ago) and I get
error: Server returned status 404: Not Found

Also, and I believe it is a related issue, when I run

flatpak remote-info --commit=4c5f24159e70054f4a276f58ac6e0669f8993d902612a7339d93701ee0f71e88 flathub org.octave.Octave

from the computer where Octave 5.2 is installed, I get the correct information but when I try the same command from the computer where Octave 6.2 is installed, I get again the error: Server returned status 404: Not Found. I find this error highly confusing since my first computer is able to fetch the remote information.

Does flatpak remote-info really fetch remote information or does it default to local information when it is available?

When I run flatpak remote-info --log flathub org.octave.Octave I get information only up to 2021-03-23 and my desired commit (from 2020-10-08) is hence not in the list. Is this the reason I cannot revert to Octave 5.2?

What procedure should I follow to install Octave with the desired commit?

Since the commit does in fact not exist (execute remote-info --verbose to show the url it tries to access) I’d assume that it was deleted, see Availability of old versions of a Flatpak at Flathub.

flatpak uses local data of the commit if available (you’ll see this with --verbose, too).
But you can try to export the desired version to move it between the computers:

The only other option I see is to build it yourself.