I can't add flathub repo

Hello. I can open flathub.org in my browser, but when I run sudo flatpak remote-add flathub https://flathub.org/repo/flathub.flatpakrepo I get this error: error: Can't load uri https://flathub.org/repo/flathub.flatpakrepo: While fetching https://flathub.org/repo/flathub.flatpakrepo: [28] Timeout was reached
I also can get ping of flathub.org from terminal.
What is the problem?

I just tried sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo and ping flathub.org and had no issues. Maybe it was a temporary thing, have you tried again?

You may check the status of the flathub services on https://status.flathub.org/.

It says that there is not any problem.

Are you in Iran (that some ISP block) or any other country that block large part of the internet?

That’s what this look like.

Yes, but it shows no issue!

I will reiterate: some ISP / CDN block certain countries. It’s not under flathub control beside not using said CDN. Clients are usually unaware that the ISP interfere in international politics by performing this kind of blockade.

The status page only show when there are outtage on flathub side. Also it’s updated manually.