I cant link ncurses to my app

hi there! I need your help please. I’m too dumb about flatpak and I want to learn. I have a project and want to build a flatpak.
here is my manifest file:

id: org.flatpak.Rogue
runtime: org.freedesktop.Platform
runtime-version: '23.08'
sdk: org.freedesktop.Sdk
command: CraftRogue
  - name: Engine
    buildsystem: cmake
      - type: file
        path: CMakeLists.txt
      - type: dir
        path: Source
        dest: Source

  - name: CraftRogue
    buildsystem: cmake
      - type: file
        path: CraftRogue/Source/CraftRogueGameEntry.cpp
      - type: dir
        path: CraftRogue/Source
        dest: CraftRogue/Source      

when I try to build with flatpak-builder, I get this error after compiling is succesfully done:

/usr/lib/gcc/x86_64-unknown-linux-gnu/13.2.0/…/…/…/…/x86_64-unknown-linux-gnu/bin/ld: CMakeFiles/CraftRogue.dir/Source/Core/Input.cpp.o: undefined reference to symbol ‘cbreak’
/usr/lib/gcc/x86_64-unknown-linux-gnu/13.2.0/…/…/…/…/x86_64-unknown-linux-gnu/bin/ld: /usr/lib/x86_64-linux-gnu/libtinfo.so.6: error adding symbols: DSO missing from command line

I think it is about ncurses library. How can I link ncurses? If you need more info I can give more. Thanks in advance.

What is that and what is it supposed to do?

I’ve tried ‘dependencies:’ and many other macros to make this work. I saw this somewhere and tried. Intention here is to link ncurses library.

Which part of the documentation list these?

I didn’t find this in document. I am just trying different things. I can build this project with cmake and run it. But I can’t build for flatpak. I am working on this for two days. That cbreak is about ncurses. I thought somehow I need to link it to ncurses in manifest.