I need help with authorising a flatpak to access files

I use gedit to edit not only my personal text and script files, but also (sometimes) system files such as /etc/fstab.

By default, the Flatpak version of gedit doesn’t allow access to certain files, fstab being one of them. gedit won’t even allow me to view the file, even if use sudo -i to run it.

I tried to fix the problem by setting Flatseal to grant gedit access to all files (screenshot attached), but that seems to have made no difference.

Please would you help me to understand where I’m going wrong, and how to fix this? (In the meantime, I have to use the outdated version in my distribution’s standard repositories. I use Ubuntu 20.04).

Thank you