'kill' Not an Option for flatpak Command (Ubuntu 18.04)

I gave flatpak a try today. Audacity was one of the apps I tried to use, but it has locked up and I can’t use kill from the command line because Audacity is not a regularly installed app.

Looking online “flatpak kill” can kill a flatpak-installed application and Flatpak’s website explicitly lists “kill” as being an option for the flatpak command but flatpak --help does not list “kill” as a valid option

flatpak --version
Flatpak 1.0.9

Restarting is the only way I can see to kill it, but it would be nice not to have to reboot when flatpak apps fail.


flatpak kill works on my Manjaro System. It is also listed under --help. Maybe your distro has a outdated version of Flatpak.

Thanks for confirming what ought to be there, but the install was done with Flatpak’s PPA per the instructions on their website, which is why I’m baffled, when the site clearly shows a “flatpak kill” command/option.

Only hting I can think is to uninstall/reinstall Flatpak and see what happens.

Double checked

“With older Ubuntu versions, the official Flatpak PPA is the recommended way to install Flatpak …”

Ubuntu Quick Setup

I saw the PPA installation method on another article about Flatpak and I just concentrated on cut/pasting the commands.

Removing and redoing with a plain apt install and see what pops up.

Reinstalled using apt install and kill is still not not an option for the flatpak command.

Opened an issue on their github.

It looks outdated, kill available since 1.1.0

I doesn’t look like you’ve installed the version from the PPA:
Version 1.0.9 is from the Ubuntu repositories (Ubuntu – Details of package flatpak in bionic-updates).
The PPA should provide 1.14.1 (Flatpak stable versions : “Flatpak” team).

It seems your PPA wasn’t correctly setup. I’m not using a Debian based distribution, therefore I can’t help with any specifics. But it seems you can check the packages with apt show flatpak or apt-cache show flatpak. This should indicate which version gets installed from which repository.

1 Like

That did the trick

flatpak --version
Flatpak 1.14.1

Thanks :slightly_smiling_face: :+1:

1 Like