Login issue to flathub.org, auth'd via KDE GitLab

I’ve tried to create an account on flathub.org, using KDE GitLab to authenticate.

I’m redirected to the following screenshotted page, from the login page and even from the homepage, I can’t browse flathub.org anymore


My browser is automatically blocking requests to

(Not sure how to categorize this post.)

Hey, I can see some errors in the logs, but I’m unsure what’s happening in your case. I did push a minor thing, but I don’t think that prevented the login to work for you.

If you unblock the ingest.sentry.io we might have more infos on your error.

I’ve authorized myself with GitHub, all resolved to my satisfaction, though seems like KDE Invent/GitLab authorization is not supported.

Thanks for maintaining the site, forum, and project!

Errors using KDE Invent/GitLab login:

I’ve deleted cookies to logout / fix the browsing issue, but the /logout endpoint never worked for me.

When I load the homepage, the page renders, with flatpak application listings, before crashing to the state visible in screenshot.

I’m trying:

  • to access Log In | Flathub in Firefox:
    Nothing appears. Marking flathub.org trusted in NoScript. → Login links appear.
    Follow KDE Invent/GitLab sign-in. Redirected back to FlatHub. → something-went-wrong
    NoScript: mark trusted Gnome and Sentry domains.
    something-went-wrong affects homepage too, on reload.

I’m using Brave primarily, I had “Shields” off and the sentry and gnome domains were blocked still anyway. Since I can reproduce the issue in Firefox, I won’t dig in further to allow the domains in Brave (I think I need to modify a global setting, I don’t want to have state to undo later).

(I think I lost draft content when the discourse also went away last night)