Media players won't play videos

hello folks

im facing some weird issue with media players on fresh linux mint installation: neither mpv, haruna or celluloid will play any video file. upon drag-dropping an ordinary mp4 file, these hang and require terminating process. the only flatpak player that works is vlc - no issues there.

i tried reinstalling flatpaks, trying out different nvidia drivers and no luck

i had no such issues on previous installation of mint - videos in mentioned players were opening without issues.

is there some runtime my installation may be missing? im using gtx 1080 gpu. or perhaps its some permissions, environment issue?

update: for sake of tests i just deployed another fresh mint install on a spare disk and same thing happens with all 3 mentioned programs above. guess this might be a distro issue.

Try running an application from the terminal with flatpak run -v <ID>, I’d assume some error message is logged.

Which nVidia driver have you installed on your host (Linux Mint) & which Flatpak extensions (flatpak list, org.freedesktop.Platform.GL.…)?

i tried all available drivers for mint for my gpu and no luck - it still pairs same extensions for flatpak tho. doesnt matter if its nvidia-driver-535 right now or 545, or the oldest 390 - problem repeats.

i did deploy another installation, this time with mint cinnamon and out of blue celluloid was able to play videos while haruna and mpv didnt. and i also tried zorin but there wont be surprises - videos were played in all 3 programs.

anyway, heres what pops in the console:

flatpak run -v org.kde.haruna
F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/xyz/.local/share/flatpak
F: Opening user flatpak installation at path /home/xyz/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: Skipping parental controls check for app/org.kde.haruna/x86_64/stable since parental controls are disabled globally
F: Opening user flatpak installation at path /home/xyz/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: /var/lib/flatpak/runtime/org.kde.Platform/x86_64/6.6/d9a07ad16df6b5858f924014ae6bc0803035276bd317da79e4a36bae2f68790b/files/lib32 does not exist
F: Allocated instance id 1147769682
F: Add defaults in dir /org/kde/haruna/
F: Add locks in dir /org/kde/haruna/
F: Allowing dri access
F: Allowing host-fs access
F: Allowing homedir access
F: Allowing wayland access
F: Allowing x11 access
F: Allowing pulseaudio access
F: Pulseaudio user configuration file '/home/xyz/.config/pulse/client.conf': Błąd podczas otwierania pliku /home/xyz/.config/pulse/client.conf: Nie ma takiego pliku ani katalogu
F: Running 'bwrap --args 41 xdg-dbus-proxy --args=43'
F: Running 'bwrap --args 41 haruna'
Gtk-Message: 19:23:17.134: Failed to load module "xapp-gtk3-module"
unknown() : Qt: Session management error: Could not open network socket

unknown() : Cyclic dependency detected between "qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml" and "qrc:/qt/qml/org/kde/desktop/MenuItem.qml"

thats for haruna and its nearly the same for other two - the differences are within messages about gui libs but no error is recorded whenever i press play or close the window

frankly, i think ill just abandon mint and swap to something else.