Newbie help with my first flatpak install

I am trying to install a flatpak to the --user context and run it. Seems like it should be straightforward but so far, no dice.

first, I installed flatpak itself to cent 7. Nothing to see here.

Second I added flathub to --user (actually this was trial and error. I first added it to the system, but realized that I had to add it to user as well. It is odd to me that I seemingly have to register flathub explicitly for --user. I would assume that I should be able to install flatpaks to the user location without being forced to configure it separately)

sudo flatpak add-remote  flathub
sudo flatpak add-remote --user flathub

next I install a flatpak

sudo flatpak install --user flathub com.obsproject.Studio

That seems to work. At least there are no errors. However, this doesnt work:

flatpak run com.obsproject.Studio
error: app/com.obsproject.Studio/x86_64/master not installed

Huh, well let me try again. Maybe there were errors that i missed somehow…

sudo flatpak install flathub com.obsproject.Studio
Skipping: com.obsproject.Studio/x86_64/stable is already installed

So is installed or not? Well it is talking about stable instead of master, maybe I have to specify stable?

flatpak run --user com/obsproject.Studio/x86_64/stable
error: app/com.obsproject.Studio/x86_64/stable not installed

What does flatpak list say?

flatpak list
flatpak list --user

Huh… So any ideas on where to go from here? Am I missing something (or a whole bunch of things?)

It would be really nice if the documentation was clearer on where these artifacts were actually stored. For instance the section that talks about using the --user flag makes no mention of where the flatpaks end up in the home directory…

Just one thing I notice, when installing as user, I believe you’re not supposed to use sudo, just run the install command as a regular user.

@jlgerber In flatpak documentation you’ll see that sudo is never used. All the commands start with the $ symbol, which means that the regular user is logged in. So no root privilege is needed even when installing system-wide (default). System versus user section explains it well: applications installed system-wide are available for all users, while apps installed at user level are obviously available for the single user.

I guess that if you run sudo flatpak list you might see the installed apps. I suggest you remove the applications and reinstall them without sudo.

flatpak remotes -v shows that /var/lib/flatpak and ~/.local/share/flatpak are the system and user installation paths respectively:

$ flatpak remotes -v
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/fede/.local/share/flatpak
fedora	system,oci
flathub	system
gnome-nightly	system

This is explained in the documentation here.


Can anyone help? I am trying to install an app and have no idea what I am doing. See screenshot

Many thanks (also have noted not to use sudo but did not before)

Hi Chris. Looks like your computer is aarch64, md.obsidian.Obsidian only available in x86_64.

Thank you, I have now discovered it is 32bit so think you are correct.

It appears that now there is an aarch64 (ARM in 64bit) build for that package that you should be able to install.

(btw neither is “32bit”)