Nothing matches in flathub remote branc

I’m sure I’m doing something wrong, but nothing will install when I use Flatpak.
I’ve tried about a dozen different things from flathub, but all I get is:
error: Nothing matches com.valvesoftware.Steam in flathub remote branch
I am using Debian 12
Debian GNU/Linux 12 (bookworm) i686
I already tried with steam and teams but nothing can be found
i need help

This because 32-bits platforms are not supported.

I’m also having this issue (or something very similar). I don’t think I’m running 32 bit (but I am on an arm system)
$ lscpu
Architecture: aarch64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Vendor ID: ARM
Model name: Cortex-A55
Model: 0
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
Stepping: r2p0
CPU max MHz: 1800.0000
CPU min MHz: 408.0000
BogoMIPS: 48.00

when I try running the manual install
$ flatpak install flathub com.valvesoftware.Steam
Looking for matches…
error: Nothing matches com.valvesoftware.Steam in remote flathub

i do have flathub in my remotes…
$ flatpak remotes
Name Options
flathub system

it’s very possible I’m doing something wrong here as I’m just starting out… ideally i’d like to know what it is!
Possibly (probably) related is that when I try to run the flatpakref file (com.valvesoftware.Steam.flatpakref) my software package manager (which I believe is gnome software)
says “Failed to install: not supported”
I’ve searched about but can’t seem to find anyone else reporting an issue so early on in the installation process

Which steam doesn’t support either. Nothing we can do.