Nothing Will Install

I’m sure I’m doing something wrong, but nothing will install when I use Flatpak.

I’ve tried about a dozen different things from flathub, but all I get is

error: Nothing matches org.gimp.GIMP in remote flathub

Like I said, it doesn’t seem to matter what I try to install. Kdenlive, OBS, Discord, Gimp, all of them have the same error.

There is no output when I do flatpak list.
The version of flatpak is 1.12.2
I’m using Fedora 35.

I’ve looked at several of the other entries here on the discourse that had the same problem, but most of them seem to be attempting to install on non-compatible hardware, 32 bit or non-intel. I’m running a Ryzen 5 3800x so it should be fine. It works fine on other distros.

Any help would be appreciated.


flatpak search gimp

yield anything?

For those who may face this problem, try running

sudo flatpak repair

No. Says No Matches Found

That didn’t work for me. Still nothing will install. Some flatpaks in the software store will install, some won’t. Nothing that comes directly from flathub, installed in the terminal (like flatpak install flathub com.todoist.Todoist) will work.

It’s difficult to say what’s wrong without some additional information. What is the output of uname -a and flatpak remote-list?

Linux hades.lan 5.15.6-200.fc35.x86_64 #1 SMP Wed Dec 1 13:41:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux


Name Options
fedora system,oci
flathub system,filtered

Also sorry for the late reply I just got back into this system.

filtered: I think this is the default flathub shipped on Fedora Silverblue that is “filtered” to just provide a select list of proprietary software.

Did you try the setup procedure (after removeing the existing flathub remote) ?