Odd appstream errors during compose

I’ve tried to update my app’s version and am getting some errors from the buildbot run I haven’t seen before (probably related to libappstream) and that I don’t see documented. Building locally shows no issues. The odder of the two errors is:

  E: filters-but-no-output
Refer to the generated issue report data for details on the individual problems.
Error: ERROR: appstreamcli compose failed: Child process exited with code 1

Naturally, there’s no “generated issue report data” that I can see in the log file.

I can guess at what the second one means:

 E: gui-app-without-icon

except that 1) there is an icon installed, 2) it is at (what I believe is) the right location ${FLATPAK_DEST}/share/icons/hicolor/scalable/apps/${FLATPAK_ID}.svg, and (most importantly) 3) building the Flatpak locally and running it shows the icon actually being used by the window manager. The only thing is that it’s just a single icon and it’s an SVG one.

Naturally, the previous version (packaged ~14 months ago) worked/works fine.

Do you have a launchable configured in your metadata?

Yes, pointing to a .desktop file that’s also there.

Thanks to hfiguiere I think I’ve figure it out. It seems that it’s no longer sufficient to have merely internally-consistent naming between metainfo, desktop and icon files; they now all need to be in files named after the app ID. I added the rename-desktop-file and rename-icon properties to fix that and have moved on past that barrier at least.

1 Like