PWAs: This Flatpak does not have write access to

Using Chrome flatpak in Clear Linux, I get this error message when attempting to install any of them Chrome apps from within Chrome (such as Twitter, Flathub Discourse etc.):

Screenshot from 2023-03-08 17-30-39

These apps, I take it, are called PWAs, which appears to stand for “progressive web apps.” So I open up Flatseal, give Chrome the required access to them folders, and still keep getting this error when attempting to install PWAs.

How do I fix this please?

I use an override on the command line:

flatpak override --user --filesystem=~/.local/share/applications --filesystem=~/.local/share/icons com.microsoft.Edge

(Adjust for your preferred browser)

1 Like

Thanks. Have you tried Flatseal as well? Would you mind giving it a try, see if it works for you? After all, this is a paradigm use for Flatseal, and it is somewhat disconcerting to see that it does not work.

Report the issue to the maintainer of the Flatpak you’re using

For Chrome Flatpak that looks like this one Issues · flathub/com.google.Chrome · GitHub

Yeah it should look something like this:

You’ve caught me on a busy day (and in the middle of a new computer setup!) so I don’t have the time to do it but if we someone each browser and took a picture of what it looks like in Flatseal and posted it here alongside the CLI instructions it would at least be a signpost for people to get working even though the solution is ugly. :smiley:

Yep, that’s precisely what I did in Flatseal. Doesn’t work.

I had the same problem but with Google Chrome. I would add the paths in Flatseal and it still would not work. I ran the flatpak override command given above, despite it already being shown in Flatseal, and then it worked.

Before I ran the command I even tried manually expanding the paths so instead of ~/.local/share/applications I manually had /home/user/.local/share/applications and that didn’t work until after I did the flatpak override command. In the end I now I have both when I inspect it with Flatseal:

image

can you send the exact code for chrome because i dont know what the name is i tried com.google.chrome and com.chrome.google and neither worked also im using a steam deck i dont know if that changes anything because its arch Linux but i still worth telling i would think

It’s com.google.Chrome you might need to get the casing right

this is the correct command if someone needs if flatpak override --user --filesystem=~/.local/share/applications:create --filesystem=~/.local/share/icons:create com.google.Chrome

1 Like

If you’re having trouble and still can’t install after adding the correct permissions in CLI or via Flatseal, make sure you run pkill chrome to kill all chrome windows. This worked for me.

I’m running Linux Mint 21.3 and installed Chrome via Flatpak and ran into the same issue. I tried all of the suggestions above, even flatpak override. That actually “almost” worked. I noticed under the ~/.local/share/applications folder it had created shortcuts but they weren’t trusted. When I clicked Open it prompted to Launch Anyway or Trust them. I clicked Trust and the icon/emblems turned from blank icons to the apps.
image

With edge it is only these two and has been working for me since the teams pwa launched

image

It “should” be the same for Chrome, but who knows. I have those same folders added in Flatseal. It did create shortcuts/launchers, but they weren’t functional until I marked them as trusted. Basically the only file-level change that made was enable execution. But from the File explorer it updates the icon also.