Qt Creator - designer module crash

I am using Pop OS at the latest update and I can’t install properly Qt Creator. I tried from shop and from terminal (3 times now) but every time I tried to launch a new project or an example it crashes when I try to edit a UI with the designer module. It seems to give no other error just shut down the window completely before opening the designer interface. The not up to date version in the standard repository works just fine, but I need the new media library to develop a project.
I did checked and installed all other dependencies as well just to be sure (additional library for QT5)

I don’t know if it’s just me with this problem or someone else had this issue.

I did all the config passages in your help page in my OS and I have access to flathub in terminal and shop (I have a lot of other apps installed perfectly working thanks to you). Seems also that Pop OS now added the function to add your repository out of the box. Can be their fault?

Keep up the good job, hope the message will help to fix some issue.