Remove Flathub apps on Chromebook

I have downloaded two copies, different versions, using Flathub. They both show up in my Linux apps on the Chromebook. How do I delete the older version? Obviously, I know very little about Linux.

An example would help, e.g. flatpak list | grep APP-ID.

Anyway, if you have two copies of the same APP-ID and you run flatpak uninstall APP-ID you’ll be asked which one you want to remove.

If the installed apps have different branches, you can specify which branch you want to remove, e.g. flatpak uninstall APP-ID//BRANCH.

There’s no such an example where a first user might expect it:

but it’s explained before in the docs:

What is an APP-ID? Calibre is the app that I have double installed. I ran dpkg --list and did not see it listed.


I took a quick look at the URL’s you recommended and was able to uninstall Calibre. Now, when I run $ flatpak list --app Calibre is no longer listed. However, when I go to the Chromebook app launcher one icon for Calibre is still shown and clicking on the icon will still launch Calibre. That indicates to me that Calibre is still installed somewhere in the Linux part of my Chromebook and I have no idea where to look.


Calibre app id is com.calibre_ebook.calibre, see its flathub page.
Anyway flatpak list --app or flatpak list --app | grep calibre shows anything?

You may have installed Calibre as RPM from Fedora regular repository.
Type rpm -q calibre or apt show calibre to find it out.

GNOME Software shows if a package is installed as RPM or flatpak.
I don’t know though which desktop your Chromebook is running and which software center is using.

Thanks. A little investigation led me to the Calibre ID.

The “flatpak list” commands both showed the correct version of Calibre installed - ver. 5.30. The downlevel version, 5.29, doesn’t show up anywhere except the Chromebook launcher.

I tried the rpm -q command and got “-bash: rpm: command not found”.

Once again, thanks for your help.


Your Chromebook is probably running Chrome OS, which could be based on Ubuntu or Gentoo distros.
If yours is based on Ubuntu, apt show calibre should return the 5.29 version.
If it’s based on Gentoo, try emerge --search calibre. More on Gentoo wiki.

At any rate, I suggest you install a software center, such as GNOME Software. Version 41 is pretty good.


I believe I am running Debian Buster. The apt show calibre command worked and I got the following in response (the reply has been shorted by deleting the product description):

Package: calibre
Version: 3.39.1+dfsg-3
Priority: optional
Section: text
Maintainer: Norbert Preining
Installed-Size: 52.9 MB
Depends: python2.7, python-css-parser, python-dbus, python-pil, python-lxml (>= 3.8), python-mechanize (>= 0.2.5), python-pkg-resources, python-cssutils (>= 0.9.9~), python-cssselect (>= 0.7.1), python-cherrypy3 (>= 3.1.1), python-dateutil, python-feedparser, python-html5-parser, python-html5lib, python-markdown, python-msgpack (>= 0.5.6~), python-pyqt5 (>= 5.11.3+dfsg-1+b3), python-pyqt5.qtwebkit, python-pyqt5.qtsvg, python-pyparsing, python-regex, python-routes, python-chardet, python-netifaces, python-apsw (>= 3.7.17), xdg-utils, imagemagick, libjpeg-turbo-progs, optipng, poppler-utils, fonts-liberation, libjs-mathjax (>= 2.1+20121028-1), libjs-coffeescript, calibre-bin (>= 3.39.1+dfsg-3)
Recommends: python-dnspython (>= 1.6.0)
Suggests: python-unrardll
Tag: implemented-in::python, interface::graphical, interface::x11,
role::program, scope::application, uitoolkit::qt, use::converting,
use::viewing, works-with-format::TODO, works-with-format::chm,
works-with-format::epub, works-with-format::html,
works-with-format::odf, works-with-format::pdf, works-with::text,
Download-Size: 23.8 MB
APT-Sources: buster/main amd64 Packages

I did not see the version, I am looking for ver 5.29, nor did I see the location so I could remove it. I have a suspicion that I need to talk to the Chrome OS support folks and ask them how to delete version 5.29 and remove the icon.

Thanks again for your time and trouble.


Sorry, I forgot about GNOME in my prior post. What is GNOME, will it be of value on a Chromebook that only uses a couple of Linux apps, and do I get it from Flatpak?


It says version 3.39.1. This page confirms it.
You can uninstall it with sudo apt remove calibre.

Run the 5.29 calibre version, then check the processes to understand which binary is running:

flatpak ps
ps aux | grep -i calibre

Post the output of these two commands.

GNOME is a desktop environment for Linux. You cannot install GNOME Software as flatpak.

You should ask other Chrome OS user which software center application use.

Thank you for your response on GNOME. I’ll save that for a later project.

Back to Calibre. I did as you suggested and here are the results. I do not understand what it is telling me, though some of the response is recognizable.

Here is the output:
abesternberg@penguin:~$ flatpak ps
Instance PID Application Runtime
2676864052 2657 org.mozilla.firefox org.freedesktop.Platform
abesternberg@penguin:~$ ps aux | grep -i calibre
abester+ 2558 2.8 4.6 1188192 132180 ? Ssl 07:14 0:08 /opt/calibre/bin/calibre --detach
abester+ 2574 0.0 0.3 149280 9644 ? S 07:14 0:00 /opt/calibre/bin/calibre-parallel --pipe-worker from calibre.utils.ipc.pool import run_main, worker_main; run_main(19, worker_main)
abester+ 2576 0.0 0.0 2384 760 ? S 07:14 0:00 /bin/sh /usr/bin/xdg-open calibre - What's new
root 2657 0.0 0.0 5188 112 ? S 07:14 0:00 bwrap --args 33 firefox calibre - What's new
abester+ 2670 0.0 0.0 5524 1004 ? S 07:14 0:00 bwrap --args 33 firefox “the link to Calibre/whats-new” was inserted here
abester+ 2672 63.4 16.2 3348472 466332 ? Sl 07:14 2:57 /app/lib/firefox/firefox “the link to Calibre/whats-new” was inserted here
abester+ 3615 0.0 0.0 6204 892 pts/0 S+ 07:19 0:00 grep -i calibre

Since new users are limited to two links, I had to modify the results.
Many thanks for your time and trouble.


This tells you that you have a calibre installation in /opt.
It is not a directory used by distro packages. IIRC Calibre has some auto-update script which installs the software in /opt (because it doesn’t want to break distro installations).

Check with ls /opt/calibre/bin has some uninstall command.
If it’s missing, I think that removing everything under /opt/calibre should be enough:

sudo rm -r /opt/calibre

Just wanted to get back to you and let you know that your advice was perfect. I was able to clean up my duplicate.