Slack flatpak does not install

https://flathub.org/apps/details/com.slack.Slack

When running the command:
sudo flatpak install flathub org.slack.Slack

It results in:
Looking for matches…
error: Nothing matches org.slack.Slack in remote flathub

I tried another app (MuseScore) using the same procedure, and it installs fine.

What is going wrong?

The application ID starts with “com”, not “org” :slight_smile:

You’re right, but unfortunately that is not the problem:

sudo flatpak install flathub com.slack.Slack

Also results in:
Looking for matches…
error: Nothing matches com.slack.Slack in remote flathub

You shouldn’t use sudo with flatpak. You have probably set up the remote per user and you should use flatpak install flathub com.slack.Slack --user.

You can also just type flatpak install slack as well.

Thanks for the tips, but unfortunately:

flatpak install slack results in: "error: No remote refs found similar to ‘slack’ "

flatpak install flathub com.slack.Slack results in : “error: Nothing matches com.slack.Slack in remote flathub”

Don’t know if this matters but I’m using a Lenovo 300e Chromebook with Linux enabled.
As I said, I did successfully install MuseScore as a flatpak, so it puzzles me why the Slack-flatpak does not work for me.

To install MuseScore, I followed these guidelines:

For now, I’m sticking to Slack on my Windows laptop then…

Just out of curiosity, did you use sudo to install Slack? I ask because the first time I tried to install Evolution using the install code copied from flat-hub I was not able to install the program. I noticed that the code copied from flat-hub does not include sudo.

I did not install Slack at all: I tried to install it with and without “sudo” but never get farther than the above mentioned error…
I did succeed to install the flatpak of the application called Musescore, as sudo. The instructions on the site “Chrome Unboxed” (see link above) suggested to use sudo.

Please paste the output of flatpak list.

Description      Application    Version Branch Arch    Origin  Installation
html5-codecs     ….html5-codecs         18.08  aarch64 flathub system
KDE Application… ….kde.Platform         5.12   aarch64 flathub system
MuseScore - Cre… …ore.MuseScore 3.4.2   stable aarch64 flathub system

Slack is only “built” for x86_64. Since it’s proprietary if Slack doesn’t offer binary for aarch64 then it won’t happen

Also FWIW you can run Slack directly in the web browser.

Thanks for your reply, now it’s clear why it doesn’t work.

I’m aware of the web version of Slack. The only thing is that it does not support screen sharing, so that’s why I tried to install the Linux-version on my Chromebook…