Some apps not following the light / dark mode change

Hi, some of my flatpak apps (Discord and Open Office) just don’t follow my laptop’s dark/light theme. For exemple when I put discord theme to follow my system theme it just uses the light theme no matter if my computer’s in dark mode. Same for Open Office. Is it a flatpak problem ? Could I make it work ? Thanks in advance

  • OnlyOffice: It happens not only on flatpak. The team is aware (issue on Github).
  • Discord: I’d guess it’s also an app’s specific issue. You can try to search and get support here

PS: I considered OnlyOffice instead of OpenOffice, since OpenOffice is not available on Flathub.

Yes it was OnlyOffice sorry. Okay well I hope it’ll soon be fixed then, thanks !

I have vision problems and light themes cause me a great deal of discomfort. One of the reasons I have snaps installed on my device was because the Flathub Theming never seemed to want to work right for me.

I found this article about setting a system-wide or app-specific theme setting and ever since I’ve had absolutely no problems.


run to view available GTK themes

flatpak search gtk3theme

download themes by running

flatpak install flathub org.gtk.Gtk3theme.Matcha-dark-sea
[Matcha-dark-sea is my preferred theme, it should be the same as your current desktop theme]

In order to manually force your preferred dark theme on any/all flatpaks you need to:

Step 1: Give Flatpak apps access to GTK themes and icons location

Give ALL Flatpak packages permission to access ~/.themes and ~/.icons:

sudo flatpak override --filesystem=$HOME/.themes
sudo flatpak override --filesystem=$HOME/.icons


Give Flatpak permission per-application to access ~/.themes and ~/.icons:

sudo flatpak override org.gnome.Calculator --filesystem=$HOME/.themes
sudo flatpak override org.gnome.Calculator --filesystem=$HOME/.icons

Step 2: Tell Flatpak apps which theme/icon to use

To tell ALL Flatpak packages which GTK theme/icon to use, first get the name of the desired item and then apply the following command:

sudo flatpak override --env=GTK_THEME=my-theme
sudo flatpak override --env=ICON_THEME=my-icon-theme


For individual per-application permissions, run:

sudo flatpak override org.gnome.Calculator --env=GTK_THEME=my-theme
sudo flatpak override org.gnome.Calculator --env=ICON_THEME=my-icon-theme

There is a way to do this using Flatseal that looks easier. I haven’t tried that way though.

If you are looking for OpenOffice, LibreOffice is on flathub. And it follow the theme settings.

1 Like