Steam/flatpak on Funtoo: libGL error

I have used flatpak to run Steam on Funtoo (Gentoo derivative, 64-bit only) for some time now. Recently, it stopped working. The Steam window appears, checks for updates and installs them if found, then crashes.

When run from a terminal as opposed from the GUI icon, it reveals this error:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I have a nvidia card, and use the nvidia binary drivers, currently version 450.57. I also have mesa installed, and checked if there’s any library conflict but it doesn’t appear so:
sudo ldconfig -p | grep -i (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib64/fltk/ (libc6,x86-64) => /usr/lib64/fltk/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/

I also tried removing the flatpak Steam installation and reinstalling from scratch, but the same error happens. I would really appreciate any help with this.