Troubleshooting flatpak-builder "filters-but-no-output" error

I am trying to build an application as a flatpak. While running flatpak-builder I get this error:

Running appstreamcli compose
Only accepting components: io.github.nmstr.taskZen, io.github.nmstr.taskZen.desktop
Processing directory: /mnt/nvme/bigProjects/.flatpak-builder/rofiles/rofiles-89bFVO/files
Composing metadata...
Run failed, some data was ignored.
Errors were raised during this compose run:
  E: filters-but-no-output
Refer to the generated issue report data for details on the individual problems.
Error: ERROR: appstreamcli compose failed: Child process exited with code 1

I cannot find any generated issue report data. As soon as I comment out this line it works:
install -D io.github.nmstr.taskZen.metainfo.xml /app/share/metainfo/io.github.nmstr.taskZen.metainfo.xml

This leads me to the belive that it is a problem with my metainfo file. I uploaded it to pastebin (<?xml version="1.0" encoding="UTF-8"?><component type="desktop-application"> - as it is a little too large for good readability in this post (abt 50 lines). This is the affected part of my manifest:

  - name: misc
    buildsystem: simple
      - type: dir
        path: .
      - install -D io.github.nmstr.taskZen.desktop /app/share/applications/io.github.nmstr.taskZen.desktop
      - install -D icon.png /app/share/icons/hicolor/512x512/apps/io.github.nmstr.taskZen.png
      - install -D io.github.nmstr.taskZen.metainfo.xml /app/share/metainfo/io.github.nmstr.taskZen.metainfo.xml
      - cp /app/bin
      - cp /app/bin

The entire manifest can again be found on pastebin (app-id: io.github.nmstr.taskZenruntime: org.kde.Platformruntime-version: 6.7 -

My projects directory structure is laid out like this:

  • flatpak
    • io.github.nmstr.taskZen.desktop
    • io.github.nmstr.taskZen.metainfo.xml
    • io.github.nmstr.taskZen.yaml
    • icon.png (also once name io.github.nmstr.taskZen.png) (512x512)
  • src
    • projects source code

What I have tried so far:

  • exclude the metadata file (works but AFAIK I need it to publish on flathub)
  • exclude the .desktop file and icon
  • isolate the install -D... command into its own module in the manifest
  • create a .sh file that runs the install -D... command, which I then run
  • rename the icon from icon.png to io.github.nmstr.taskZen.png
  • exactly copy someone else’s metainfo file and the command they use to install it
  • same as above but this time changed the ids to match with my project

At this point I am really lost at what this might be. I appreciate any help! Thanks in advance.

I suspect the .desktop file and the used categories or it’s not able to link to the categories. But we all struggle with this part. @bbhtt seems to have a hand for solving these, even with not enough info.

That seems weird, as when removing the metainfo file it works, even the .desktop file works then. I tried playing around a little witht the Categories (the Categories in the .desktop file; I assume these are the ones you meant). Nothing changed anything. Also it showed up in the correct categories, when I build without the metainfo.
Anyways, you said “even without enough info”. I can provide as much info as needed. I just need to know what actually is needed.

Can you share the manifest in a way I can build and check? dir sources mean I don’t have the sources.

Mmm nevermind, the id tag in metainfo is wrong it’s taskZen not taskzen.

Also desktop file is missing an Icon key which will be a problem later on

Thanks a lot. Capitalizing the Z in the id did the trick. Now looking at this error it feels really dumb that I spend almost a day of troubleshooting for this. Anyways. I also added the icon as well and everything works. Thx.