Unable to Install Spotify Client Flatpak for 32-bit PC's

I installed flatpak via apt-get on my 32-bit Laptop running antiX Linux, Version 19.2 Marielle Franco, and I added the flathub.flatpakrepo rep per the istructions for Debian systems.

After rebooting my laptop, I tried to install the 32-bit Flakpak for the Spotify client without success.

I get the following error. Looks like there is a problem with the Spotify 32-bit Flatpak file. Any ideas on how to get it fixed?

$ flatpak install flathub com.spotify.Client
Looking for matches…
Required runtime for com.spotify.Client/i386/stable (runtime/org.freedesktop.Platform/i386/18.08) found in remote flathub
Do you want to install it? [Y/n]: Y

com.spotify.Client permissions:
ipc network pulseaudio x11 dri
file access [1] dbus access [2] bus ownership [3] tags [4]

[1] xdg-music:ro, xdg-pictures:ro
[2] org.freedesktop.Notifications, org.gnome.SessionManager, org.gnome.SettingsDaemon
[3] org.mpris.MediaPlayer2.spotify
[4] proprietary

    ID                                            Arch         Branch         Remote         Download
  1. [✓] org.freedesktop.Platform i386 18.08 flathub 292.7 MB / 306.7 MB
  2. [✓] org.freedesktop.Platform.Locale i386 18.08 flathub 161.0 MB / 316.0 MB
  3. [✓] org.freedesktop.Platform.VAAPI.Intel i386 18.08 flathub 1.9 MB / 1.9 MB
  4. [✓] org.freedesktop.Platform.html5-codecs i386 18.08 flathub 3.3 MB / 3.4 MB
  5. [✗] com.spotify.Client i386 stable flathub 32.7 MB / 109.0 MB

Error: While downloading https://repository-origin.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb: Connection terminated unexpectedly
error: Failed to install com.spotify.Client: While downloading https://repository-origin.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb: Connection terminated unexpectedly
user@antix1-laptop:~

This won’t work as the freedesktop runtime isn’t available for 32bits architectures anymore. The one you’re trying to install is pretty old and the link is probably broken.

That build should be removed though.

Thanks for the comment. But I am a little confused. As you can see from my previous post, the 32-bit version of freedesktop appeared to download and install okay. It was just the 32-bit version of the spotify client that would not download properly. Looks like it might be corrupt.

Spotify doesn’t allow us to re-distribute the binary. So the install step downloads spotify from upstream & install it. As that build is very old, the url is broken and hence it’s not working for you anymore.

Thanks for the info. Yes, I see that flatpak is trying to download the deb file for the 32-bit Spotify client from the Spotify repos. I tried to download it directly using curl but it failed. It sure looks like the .deb file is corrupt or perhaps the permissions are set incorrectly.

I have reported the problem to the Spotify Community Forums.
See

I am hoping Spotify will fix the corrupt .deb file or at least inform me that it no longer develops and supports the 32-bit Spotify client.

I see the problem and have a solution.

The flatpak for the 32-bit version of the Spotify Client on the Flathub repos uses the WRONG URL for the .deb binary for the 32-bit Spotify client.

The URL should be http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb

NOT https://repository-origin.spotify.com/ etc etc.

I was able to easily download the .deb binary (that is needed by the flatpak) for 32-bit version of the Spotify Client from the correct URL.

So I hope someone updates the flatpak for the 32-bit version of the Spotify Client on Flathub with the right URL.

Until someone does update the flatpak with the right URL, is there a way I can install the flatpak using the manually downloaded .deb file from the Spotify servers?

It’s only 64-bit support right now

To repeat after Bilel: 32-bit Intel processors are no longer supported. Nothing to update here, it will be removed if anything.