Updating Firefox

Hello, I installed the Flatpak Firefox a while ago and I have noticed that it does not do any upgrading to the newer versions because “Updates are disabled by your system administrator”. My environment is the Crostini Linux on a Chromebook. Is there some way to “enable” my updates so I can keep up with the current version of Firefox? I tried to reinstall the latest version but I just get a message that it’s already installed.
Thanks

Did you try:

flatpak update firefox

flatpak-update — Update an application or runtime

Or is your question about enabling in app updates?

Thank you for responding. I tried your suggestion of “flatpak update firefox” but got an error back of “Invalid id firefox: Names must contain at least 2 periods”. So obviously it wants additional path information for firefox which I don’t know. I also looked at your link and tried to read through it but my eyes glazed over because it was way over my head. I’ve only been dabbling with Linux for a couple years (after 35 years of DOS, Novell and Windows). I like learning new things but I find this pretty hard.

The idea of just enabling app updates sounds appealing if that’s possible. I don’t see why the default seems to be to have that disabled.

That’s because flatpak update firefox is invalid. It expect an app-id, like org.mozilla.firefox. But if flatpak upate didn’t offer it, then I doubt it will be different.

Now if you machine using an ARM processor instead of an Intel-compatible one (you didn’t say), then it’s unlikely to work as there is no Flatpak version of Firefox for anything else than x86_64…

(sadly, and that’s not something the Flathub maintainer can fix)

Thanks for your feedback. My machine is a Chromebook with an Intel processor. I tried you suggestion of org.mozilla.firefox and viola, it worked!! Once you know the solution, it usually doesn’t seem so difficult. I just wish I could have found this information on Flathub’s web site so I didn’t have to bother you folks. Thanks again for your help!

Glad it’s sorted out.

I am new to flatpak too. I forgot app-id needs to be used.

If you want to see all the apps installed through flatpak and their app-id’s you can use this command:

flatpak list

“flatpak list”, very nice! Thank you very much. :slight_smile:
I guess this topic is complete and should be closed.

1 Like