Using flatpak and installing apps

Perhaps this is the wrong place to ask but I need help installing a Flatpak Application in Ubuntu Linux. I have followed the instructions for first of all installing flatpak and then installing Betaflight Configurator. On doing the last step I get the following error message: error: Nothing matches io.github.betaflight.BetaflightConfigurator in remote flathub
Any suggestions or could you direct me to somewhere I might get an aswer?

Can you tell us what instructions have you followed? Also the output of flatpak remote-list would be useful.

and then these:
(at the bottom of the page) and the output from flatpak remote-list Name Options and on next line flathub system.

Well, that’s weird. Try running flatpak install with sudo (although it shouldn’t be necessary).

If that doesn’t help, purge the content of /var/lib/flatpak/ and run flatpak install

by purge do you just mean delete the contents?

Yes, sudo rm -rf /var/lib/flatpak/* for example.

so when i do that i get
error: No such ref ‘app/io.github.betaflight.BetaflightConfigurator/i386/stable’ in remote flathub

by ‘that’ i mean ‘sudo rm -rf’ followed by the flatpak install line you gave earlier.

Could you tell us which version of Ubuntu you are using? Is it the standard 64 bits or 32 bits? What version of flatpak is installed (you can type flatpak --version to get it)

It’s possible that after removing the /var/lib/flatpak folder you have to install flatpak again and add the flathub repo:

# Reinstall flatpak just in case
sudo apt-get install --reinstall flatpak

# Add the flathub repo
flatpak remote-add --if-not-exists flathub

# Search something
flatpak search beta
Description                                                                Application                        Version    Branch Remotes
GeoGebra Beta - Dynamic mathematics software                               org.geogebra.GeoGebra              6.0.546.0  beta   flathub-beta
Betaflight Configurator - Crossplatform configuration tool for the Betafl… …betaflight.BetaflightConfigurator 10.1.0     stable flathub
FreeTube - An Open Source YouTube app for privacy                          io.freetubeapp.FreeTube            0.7.2 Beta stable flathub

# Install Betaflight
flatpak install flathub io.github.betaflight.BetaflightConfigurator

My machine is 32 bit and I’m using Ubuntu 18.04.4.

I’m afraid the app you are looking for is not available for 32 bit:

flatpak remote-info flathub io.github.betaflight.BetaflightConfigurator --arch i386
error: Error searching remote flathub: Can't find ref io.github.betaflight.BetaflightConfigurator/i386
flatpak remote-info flathub io.github.betaflight.BetaflightConfigurator --arch x86_64

Betaflight Configurator - Crossplatform configuration tool for the Betaflight
flight control system

        ID: io.github.betaflight.BetaflightConfigurator
       Ref: app/io.github.betaflight.BetaflightConfigurator/x86_64/stable
      Arch: x86_64
    Branch: stable
   Version: 10.1.0
   License: GPL-3.0
Collection: org.flathub.Stable
  Download: 108,1 MB
 Installed: 291,1 MB
   Runtime: org.freedesktop.Platform/x86_64/18.08

       Sdk: org.freedesktop.Sdk/x86_64/18.08
    Commit: ee6564c5b95bc89f20ce659e9590a3fd901ce9e20baf5060348b01334a67fe21
    Parent: 372843f6d21bf42eb9cad9e069673bb8e4d82856b4d6989c7aa4eb3a0a3d5f62
   Subject: add OARS content rating (36a93300)
      Date: 2019-06-29 07:26:51 +0000

Thanks jgarciao. That explains it then. I’ll probably be upgrading to 64 bit machine soon. The one I have now - a Lenovo 3000 N100 - has been a real workhorse for me and served me well.

Hey, I am also having some Flatpak issues. I was trying to install Jamovi, and I got this error message:

GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Flatpak system operation Deploy not allowed for user

What does it mean, how can I get around it? The Jamovi help forum suggested I come here for help.

There is a semi-similar issue in this this link and it could be that PolicyKit (a component of the operating system) is not properly configured in your computer.

As a workaround maybe you can also install the apps with --user:

flatpak remote-add --user --if-not-exists flathub
flatpak install --user flathub org.jamovi.jamovi

Hey, it worked! But, when I run Jamovi, a blank window opens. Plus, Jamovi doesn’t appear installed under my Software folder/thing. Any ideas?

About missing desktop launcher, please make sure you have followed Flatpak installation instructions here:
You may need to reboot but whatever Flatpak you install, it should be visible in menu.

About blank screen, no idea. It works here, you should probably ask Jamovi folks if they have any suggestions. I don’t think it’s flatpak issue.

I’ve followed the installation instructions, many times at that. I’m not sure if it’s evident (I didn’t say earlier), but I’m attempting this on a Chromebook. I also thought a system restart might be needed to run it, but I still get the same issue.

Maybe it’s because you are using a very old version of flatpak? What does $ flatpak --version say?

According to the comments under this article:, you could try

$ sudo apt-get -t stretch-backports install flatpak

Version 1.2.5, the latest version.