Wrong origin flathub for update

I had Tauon Music installed as Flatpak on my computer (Ubuntu 20.04.4). Suddenly after a normal restart I could not find it anymore. I tried to install it again but it keeps giving me this error.

Warning: Wrong origin flathub for update
Error: Wrong origin flathub for update
error: Failed to install com.github.taiko2k.tauonmb: Wrong origin flathub for update

After that I tried to install another Flatpak application, just to see if the problem was only in your app or a general problem from Flatpaks. I could install the other app without any issues. So I guess it could be something wrong with yours.

Other unsuccessful things tried so far:

  • flatpak repair --user && flatpak repair --system
  • upgrade to Ubuntu 22.04
  • Install from Software Center

I have already created an issue (https://github.com/Taiko2k/TauonMusicBox/issues/797) on Github repo. The developer does not know how to further debug the problem.

Thanks,
Salus

1 Like

What happens if you run flatpak remotes?

You can also try re-adding the flathub remote

# Remove the Flathub remote
flatpak remote-delete flathub
# Re-add the remote
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

It doesn’t seem to be an issue with com.github.taiko2k.tauonmb since that package installs properly on my machine

Hi dginovker
I’ve tried removing the remote with the consequently uninstalling off all flatpaks in my machine. After adding the remotes again it still does not work with tauon music.

It seems like some permissions must be granted on the installation and it “seems” to work when I run the install command with sudo, however, even though the install finishes with no errors, no application is installed. Thus, not showing up on flatpak list and not being callable through flatpak run.

It is pretty confusing since it is the one and only app that fails on install. I am able to install everything else from flathub without any kind of problem.

I have tried to reinstall all previous flatpaks and apparently, the following apps have exactly the same error:

  • org.gimp.GIMP
  • com.github.huluti.Curtail

do all these apps have something in common? What exactly could be wrong? I am pretty lost…