Chrome os firefox doesn't run

I had flatpak and firefox running on my Chromebook. Something happened and I had to powerwash my Chromebook. I reinstalled Linux and installed flatpak and the flatpak repo’s. I then installed firefox. There were no errors I could see. I rebooted the linux virtual machine and ran:

sudo flatpak run org.mozilla.firefox

and got this error:

error: app/org.mozilla.firefox/x86_64/master not installed

I tried uninstalling the Linux virtual machine, rebooted and then reinstalled the Linux virtual machine. I repeated the flatpak install process but got the same results.

my chromebook is running Version 97.0.4692.77 (Official Build) (64-bit).

Any ideas?



Additional info, this is what flatpak list shows:

Name              Application ID                    Version Branch Installation
Freedesktop Plat… org.freedesktop.Platform          21.08.9 21.08  user
Mesa              ….freedesktop.Platform.GL.default 21.3.3  21.08  user
openh264          org.freedesktop.Platform.openh264 2.1.0   2.0    user
CrosAdapta        org.gtk.Gtk3theme.CrosAdapta              3.22   user
Firefox           org.mozilla.firefox               96.0.1  stable user

you should NOT “sudo flatpak run …”

I assume you mean to run it without sudo. If I do this is what happens:

$ flatpak run   org.mozilla.firefox
bwrap: Can't mount proc on /newroot/proc: Operation not permitted
error: ldconfig failed, exit status 256

Some setup had to be done to run flatpak before that you didn’t do again. (I know nothing about Chrome books)

See Unable to Run OBS - #5 by Sgs1488

I did the setup that was on the flatpak page for Chrome os:

Is that what you mean? Is there something else not listed there?

@ Sgs1488’s solution at the bottom of solved this problem for me.