Some apps in flathub are no longer working properly


Using Rocky Linux 8.9.

In recent days, some apps in flatpak are no longer working properly (they used to work fine) and do not show their window / GUI properly - eg some of the GUI has black rectangles in it. The GUI does not respond to mouse clicks sometimes. Also they are intermittently taking 100% CPU processing.

An example app that is having this issue is flatseal.

Other apps still function fine, such as shortwave.

Any help much appreciated. Please let me know if I can provide further info.

AMD/INTEL/Nvidia? Do you see anything in the terminal, if you start a flatpak from there.

I would guess it’s a regression in rocky linux - but hard to know without more data.

It would also be valuable to know which runtimes you have tested, if older ones work.


Thanks for the quick reply and your help :slight_smile:

The video card is:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

CPU is:
Intel(R) Core™ i5 CPU M 540 @ 2.53GHz

Running in the Terminal:
flatpak run com.github.tchx84.Flatseal
produces the same issues unfortunately.

Please let me know if there is more info I can provide or something I can try.

@tingping - Thank you also for your reply.
I am sorry but I am an end user of flatpak and do not now what it means to test runtimes.
I tried to learn more about what you mean by eg searching for:
flathub install older runtime
and found articles like:

in which the OP does not understand things either
Downgrading | Flathub Documentation which seems to be oriented to developers eg using terms like “Then you deploy the commit:” which I have no idea of what this would mean.

I think the most sensible thing you can do as a user is report this to rocky linux and see if they have more reports of this.

I have the same problem and think that the problem is the Gnome 45 runtime. All Installed apps using this runtime are not working.

I just tried Firmware which uses Gnome 45 and that seems fine on my system

I just noticed that flatpak has a “repair” command. Seems like a sensible thing to try. I have ran and it did not complete properly. I am going to make another post about this.

If you start the app from the commandline, what does the commandline say?

Today I updated the Gome 45 runtime and this fixed the problem.